SuperBeam

- the simple answer to simply supported beams ... and more

Were you a SuperBeam 2 user?

SuperBeam 2 (for DOS) and SuperBeam 3 (for Windows 3.x) are long obsolete. They have been replaced by SuperBeam 4 (for Windows XP/Vista/Windows 7/8). Click here for full details

All registered users of SuperBeam 1-3 can buy the current version at a special upgrade price. Price list

Remember it's SuperBeam, not Super Beam or SupaBeam